[dancer-users] Namespace for load_app modules
dkrotkine at gmail.com
Sun Dec 8 23:38:17 GMT 2013
And I'll make the tactical mistake of jumping into this thread after a
long day :) and say that I agree with Sawyer and Yanick.
I'd like to add this:
Let's say you publish Dancer::App::MyGreatApp for other people to use.
Some of them will use it as is, like without touching it, but others
(most of them ?) will want to tweak it, change some stuff, expand on it,
And it will be much easier if it's a plugin.
If you know POE, I think I could compare what you're trying to publish
as a POE component. That would be translated in a Dancer::Plugin.
Now, if your code can't fit in a plugin, then first, we'd like to see
the code, and second, if it's really out of the Plugin's league, then we
could think of something else. Like Dancer::Component. But I honestly
doubt it can't fit into a Plugin
On Sun, Dec 8, 2013, at 08:42 AM, Yanick Champoux wrote:
> >> Why can't this be a plugin, by the way?
> I'll make the tactical mistake of jumping into this thread before my
> first coffee, and say that I agree with Sawyer: I think that those
> modules could very well find their home in the ::Plugin namespace.
> Typically, plugins do add keywords, but they don't have to: they can
> also extend the functionality of the application itself.
> Henk, do you already have some of your code on GitHub? If it is, it
> would probably be easier to use one of them as an example of that I mean.
> dancer-users mailing list
> dancer-users at dancer.pm
More information about the dancer-users