[dancer-users] Namespace for load_app modules
xsawyerx at gmail.com
Sun Dec 8 23:14:11 GMT 2013
We didn't mean Dancer::Plugin::App...
On Sun, Dec 8, 2013 at 11:53 PM, Henk van Oers <hvo.pm at xs4all.nl> wrote:
> On Sun, 8 Dec 2013, Yanick Champoux wrote:
> Why can't this be a plugin, by the way?
>> I'll make the tactical mistake of jumping into this thread before my
>> first coffee, and say that I agree with Sawyer: I think that those modules
>> could very well find their home in the ::Plugin namespace.
> The namespace Dancer::Plugin::App sounds good.
> Typically, plugins do add keywords, but they don't have to: they can also
>> extend the functionality of the application itself.
> Typically, load_app's do not add keywords.
> That's why the Subject is "Namespace for load_app modules".
> Henk, do you already have some of your code on GitHub? If it is, it would
>> probably be easier to use one of them as an example of that I mean.
> On github I have Amsterdam.pm
> But I do not want to claim the Amsterdam namespace on CPAN.
> Dancer::Plugin::App::Amsterdam will do just fine.
> I'll make a Dancer::Plugin::App::AmsterdamX.pm
> to make things clear.
> Yes, that's Sawyer's namespace.
> See http://amsterdamx.pm/
> dancer-users mailing list
> dancer-users at dancer.pm
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the dancer-users