[Dancer-users] Runtime error having to do with hooks (which I don't use)

Brian E. Lozier brian at massassi.com
Thu Jun 9 21:12:39 CEST 2011

On Thu, Jun 9, 2011 at 12:11 PM, David Precious <davidp at preshweb.co.uk> wrote:
> [CC'd list back in]
> On Thursday 09 June 2011 20:02:27 Brian E. Lozier wrote:
>> I'm using Dancer-1.3051.  Did you try it under plackup?
> Yeah, I tried it both by running bin/app.pl directly, and starting it by
> running plackup bin/app.pl - both worked.
>> I will try to repro it with a scaffolded app.  In my app I have one before
>> filter, one before_template filter, one after template filter.

My mistake, I have one before filter, one before_template filter and
one after filter (not after template).

> Ah, OK - I'll add a before handler and an after_template to my test case and
> see if that changes anything.
>> It's odd that
>> the first request works and every subsequent ones don't work.
> Indeed.  I suspect it's something like a side-effect of what one of the
> handlers returned being inadvertently set, or something.
> --
> David Precious  ("bigpresh")
> http://www.preshweb.co.uk/
>   "Programming is like sex. One mistake and you have to support
>   it for the rest of your life". (Michael Sinz)

More information about the Dancer-users mailing list