[Dancer-users] Deployment trouble

Maurice Mengel mauricemengel at gmail.com
Thu Jan 20 19:07:08 CET 2011


I have a problem with my dancer webapp deployment. I don't know where
to look anymore. I had the old version of my webapp deployed the same
way and it worked well. Now, I update it and it doesn't work any more.

Dancer is and was version 1.2003. I updated Plack to current version,
but no change. I had it in Apache using plack like described in

Current setup:

<VirtualHost 85.xxx.36.140:80>
        Servername spk.mimo-project.eu
        DocumentRoot /var/www/vhosts/mimo-project.eu/webapps/Salsa_OAI
        #SetEnv DANCER_ENVIRONMENT "production"
        ErrorLog /var/www/vhosts/mimo-project.eu/webapps/logs/error_log
        CustomLog /var/www/vhosts/mimo-project.eu/webapps/logs/access_log common

        <Directory /var/www/vhosts/mimo-project.eu/webapps/Salsa_OAI/public>
                AllowOverride None
                Order allow,deny
                Allow from all

        <Location />
                SetHandler perl-script
                PerlHandler Plack::Handler::Apache2
                PerlSetVar psgi_app

After update, I get a segmentation fault in
/var/logs/apache2/error.log (ubuntu) everytime I try to access webapp:

[Thu Jan 20 18:20:18 2011] [notice] child pid 32575 exit signal
Segmentation fault (11)

That's all I get (unless I switch to development environment, as above).

The strange thing is that I can run the webapp as standalone, both in
production and development environment. I can run it also thru plackup
via HTTP::Server::Simple.

Somethine else. I changed the httpd.conf file and tried both
production and development mode. Debug messages then go to
/var/logs/apache2/error.log although I explicitly specify
    ErrorLog /var/www/vhosts/mimo-project.eu/webapps/logs/error_log

I checked my paths a hundred times. The ErrorLog file exists. I also
tried to make sure that the permissions work and tried with 777 just
to be sure. But why doesn't apache log the errors in the ErrorLog
which I gave it?

In development mode, I see that my dancer app fails during
initialization when it loads the sqlite db. Why would it do so only
when started from apache?

I hope you have an idea.


More information about the Dancer-users mailing list