[dancer-users] template parameters are not working

Kadir Beyazlı kadirbeyazli at gmail.com
Fri Jan 15 22:40:04 GMT 2016

Hi All,

My project at my local pc was working when I tried 2 weeks ago.
Now I tried but realized that template toolkit parameters are not set.
I see following when I click on "View Page Source"

<html lang="tr">

 <meta charset="<% settings.charset %>">
 <meta name="viewport" content="width=device-width, initial-scale=1">
 <link rel="stylesheet" href="<% request.uri_base %>/css/bootstrap.min.css">
 <script src="<% request.uri_base %>/javascripts/jquery.min.js"></script>
 <script src="<% request.uri_base %>/javascripts/bootstrap.min.js"></script>
 <link rel="stylesheet" href="<% request.uri_base %>/css/mystyle.css" />

I checked config.yml whether I changed start-end tag of template toolkit
but I see that it is corrrect.

# config.yml
template: "template_toolkit"
      start_tag: '<%'
      end_tag:   '%>'

What may problem be? Last week I upgraded Ubuntu version from 15.04 to
15.10 but this should not be reason.
I installed Dancer2, Template again in case upgrade caused a problem but
nothing changed

I am starting my project with plackup command

*Kadir Beyazlı*
*GSM : +90 535 821 50 00*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.preshweb.co.uk/pipermail/dancer-users/attachments/20160116/af0af8ac/attachment.html>

More information about the dancer-users mailing list