[Dancer-users] Feedback requested: streaming support

sukria sukria at sukria.net
Fri Aug 19 14:45:25 CEST 2011

On Fri, 19 Aug 2011 09:53:27 +0200, damien krotkine <dkrotkine at gmail.com>
> OK here is the first thought : I'm not sure it's a good idea to add
> more options and stuff to send_file ? If you want to stream stuff, it
> opens the door to a lot of options, and modes, as you demonstrates in
> your email. So what about send_stream instead of send_file ? My other
> comments assume you decide to stick with send_file. But I'd rather see
> send_stream() :)

I agree with dams, I was going to suggest to rename the action "stream"
but send_stream sounds even more accurate and intuitive. 

My two cents ;)

More information about the Dancer-users mailing list