[Dancer-users] case insensitive param keys

Alexis Sukrieh sukria at sukria.net
Thu Oct 7 10:11:11 CEST 2010

Le 07/10/2010 10:04, damien krotkine a écrit :

> In this case, "params_lc" would be a bad name. What about
> "params_normalization" or something similar, that can accept either
> 'uppercase', 'lowercase', or a code reference?
> Also, some people may want to normalize the params only in some part of
> the application. Do we want to handle that ?

I agree with Damien, and am not sure if this kind of feature should be 
provided by Dancer's core.

We should be careful not to implement all features we may think of. I 
understand this can be useful in some cases, for some purposes. But we 
don't want Dancer to hanlde every possible cases, natively.

We're a micro-framework, remember?

So my suggestion would be to provide a plugin for that. Like 

If someone wants to start working on that plugin, I'd be happy to help, 
but my priority (as well as Franck's) is to finish 1.2 and we have still 
some issues to solve.


Alexis Sukrieh

More information about the Dancer-users mailing list